Delayed notifications
Incident Report for Opbeat
Resolved
We worked through the queue. Notifications should not be delayed anymore
Posted over 1 year ago. Aug 02, 2016 - 10:03 UTC
Identified
Due to an onslaught of traffic, our notifications are currently delayed by a few minutes
Posted over 1 year ago. Aug 02, 2016 - 09:53 UTC